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Practices, October 12 and 13

Numerical Simulation of a Heat Transfer Problem with ANSYS

Jörg Wolters, FZJ – ZEA-1
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1. day

 Introduction to FEM (finite element analysis)

 Exercise: Cooling of electronic components

a) building the geometry

b) defining material properties

c) simplified thermal simulation

d) more precise thermal simulation with fluid elements

2. day

 Introduction to CFD (computational fluid dynamics)

 Exercise: Cooling of electronic components 

e) CFD simulation

Numerical Simulations of a heat transfer problem with ANSYS
Contents
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 Public known from e.g. crash simulations for automobile industry

Source: Institute for technical and numerical mechanics, University of Stuttgart

Introduction
 Finite Element Method (FEM)
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 The Finite Element Method (FEM) is a numerical method for solving problems (differential 

equations) of  engineering and mathematical physics.

 Useful for problems with complex geometries, loadings, and material properties, for which 

analytical solutions are not available any more.

 Applicability: structural/stress analyses, heat transfer, electromagnetic fields, crash , fluid 

dynamics, fracture mechanics, acoustics …

 The whole domain is divided into small elements for which the field variables (e.g. 

displacements for mechanical problems) are interpolated from values at the corners (nodes) 

by approximating functions. The values of the field variable at the element nodes become the 

unknown of the problem, from which all other values can be derived (e.g. strains and 

stresses for structural analyses).

 Recombining all sets of element equations into a global system of equations, the problem 

can be solved for the whole domain.

 Important: The solution of a finite element analysis is not exact but only an approximation 

that strongly depends on the discretization and the approximating 

functions.

Introduction
 Finite Element Method (FEM) – how does it work?

nodal displacements element displacements

Stresses (and forces)

approximating

functions

derivation

material law

strains
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Introduction
 Finite Element Method (FEM) – what are the Benefits?

identification of faulty designs and weak spots in 

the early development phase

analysis of complex systems possible

minimizing costly physical testing*

results are available everywhere in the system

fast and easy design optimization in terms of

material stressing, weight, stiffness …

assessment of lifetime

enhanced product quality

shortening of  

development phases

reduction of 

development costs 

*nevertheless, in most cases experiments are also indispensable in prototype development

and only the combination of simulations and experiments will lead to optimal results
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Exercise: Cooling of electronic components
 Exercise details

 Geometry

cooling pipe

electronic components on carbon fiber laminate structure

connected to carbon foam
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Exercise: Cooling of electronic components
 Exercise details

 Geometry

cooling pipe

(steel)

electronic components

(ceramics)

carbon fiber laminate

carbon foam

3

3

0
.5

0
.2

0
.1

52

9

11



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 8 von 99

Exercise: Cooling of electronic components
 Exercise details

 Boundary Conditions

 He 

mass flow rate: 0.5 g/s

pressure: 10 bar

density: 1.634 kg/m³

specific heat capacity: 5200 J/(kg K)

conductivity: 0.15 W/(m K)

viscosity: 2e-5 N·s/m²

 Electronics

heat generation:1.5 W per block

total heat: 24·1.5 W = 36 W

inlet temperature: 20°C

Inlet velocity: ~120 m/s

Reynolds number: ~17700 (turbulent)

heat transfer coefficient: ~ 4000 W/(m K)

Thermal conductivity of materials:

carbon foam: 70 W/(m K)

ceramics:     4.5 W/(m K)

steel: 15 W/(m K)

carbon fiber laminate: 

10 W/(m K) (in plane)

0.5 W/(M K) (vertical)
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Exercise: Cooling of electronic components
 set up the simulation project

 Start WB16.2 from desktop

 Drag and Drop with LMB (left mouse button) ‘Steady-State Thermal’ to Project Schematic

 Main Menu => File => Save As… (choose directory and project name)

2

preprocessing

solution

Post-processing
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Exercise: Cooling of electronic components
 part a): building the geometry

 Double-Click (LMB) on Geometry

Main Menu

Tree Outline

Details View Graphics

Toolbars

Sketching / Modeling mode
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Exercise: Cooling of electronic components
 part a): building the geometry - toolbars

 Selection Tools:

drag from left to right: items completely enclosed are selected

drag from right to left: items completely or partially enclosed are selected

 View options:
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Exercise: Cooling of electronic components
 part a): building the geometry – foam

 Main Menu => Units => mm

 Main Menu => Create => Primitives => Box

 Details View: Enter dimensions (point 1: -5mm, -1.5mm,0mm; diagonal: 10mm, 3mm, 200mm)

 Toolbars =>                    (will create box)

 Main Menu => Tools => Freeze (protects body from being merged with other bodies) 
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Exercise: Cooling of electronic components
 part a): building the geometry – polyethylene layer

 Main Menu => Create => Primitives => Box

 Details View: Enter dimensions (point 1: -5mm, 1.5mm, 0mm; diagonal: 10mm, 0.2mm, 200mm)

 Toolbars => 

 Main Menu => Tools => Freeze

 Toolbars =>       (Zoom to fit / ‘F7’) and       (Save Project / ‘Ctrl’ + ‘s’)
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Exercise: Cooling of electronic components
 part a): building the geometry – cooling pipe / outer dimension

 Main Menu => Create => Primitives => Cylinder

 Details View: 

 Toolbars =>

 Main Menu => Tools => Freeze
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Exercise: Cooling of electronic components
 part a): building the geometry – cooling pipe / inner dimension

 Main Menu => Create => Primitives => Cylinder

 Details View: 

 Toolbars =>                  

 Main Menu => Tools => Freeze

 Toolbars =>  
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Exercise: Cooling of electronic components
 part a): building the geometry – intersect cylinders

 Toolbars =>       (Zoom in): 

 Toolbars =>        (Select Bodies ‘Ctrl’ + ‘B’) 

 Toolbars =>          (Box Select): Select both cylinders

 Main Menu => Create => Boolean

 Details View: 

 Toolbars => 
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Exercise: Cooling of electronic components
 part a): building the geometry – subtract cylinders from foam

 Main Menu => Create => Boolean

 Details View: 

 Toolbars => 



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 18 von 99

Exercise: Cooling of electronic components
 part a): building the geometry – generating parts

 Toolbars:            => Select all bodies

 RMB:
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Exercise: Cooling of electronic components
 part a): building the geometry – electronic components

 Main Menu => Create => Primitives => Box

 Details View: 

 Toolbars =>                  

 Main Menu => Tools => Freeze
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Exercise: Cooling of electronic components
 part a): building the geometry – electronic components

 Main Menu => Create => Pattern

 Details View: 

 Toolbars =>                  
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Exercise: Cooling of electronic components
 part a): building the geometry – suppress fluid part of pipe

 Toolbars =>        (Zoom in)

 Toolbars => select inner part of pipe

 RMB: Suppress Body
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Mark YZPlane (RMB) 

 Toolbars =>        (New Sketch)

 Mark Sketch 1: 

 ‘Sketching’

modus                 
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Sketching Toolboxes => Draw => Line 

 Draw line along pipe axis in Graphics Window

Important: 

- C-Symbols must be visible when creating the start and end point of the line

- the line should be slightly longer than the cooling pipe, so that end points can easily be selected

start

end
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Sketching Toolboxes => Dimensions => Vertical 

 Click on red axis and next on starting point of line

 Details View:

(enter exact distance)
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Sketching Toolboxes => Dimensions => Vertical 

 Click on both end points of line

 Details View:

(enter exact distance)

 Toolbars => 
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Main Menu => Concept => Cross Section => Circular   (program will automatically leave the 

sketching modus)

 Details View
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Main Menu => Concept => Line from points

 Details View:

Point Segments: Select start point (LMB) and end point (‘Ctrl’ + LMB) from line sketch

note: direction important

 Toolbars => 

start

end
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Exercise: Cooling of electronic components
 part a): building the geometry – centerline of cooling pipe

 Tree Outline => Parts, Bodies 

 =>                   LMB  

 Details View 

Suppress line again, since

not needed for first simulation

 Tree Outline =>

RMB => Suppress Body
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Exercise: Cooling of electronic components
 part a): building the geometry – using symmetry conditions

 Tree Outline => XYPlane (LMB)

 Main Menu => Create => New Plane

 Details View:

 Toolbars =>

(rename)
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Exercise: Cooling of electronic components
 part a): building the geometry – using symmetry conditions

 Main Menu => Tools => Symmetry

 Details View:

 Toolbars => 

 Toolbars => 

 Main Menu => File => 

Close DesignModeler

(select plane of previous step)
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Exercise: Cooling of electronic components
 part b): defining material properties

 Double-Click on ‘Engineering Data’

 Notice: Only thermal conductivity is

needed for steady-state thermal analysis

defined materials

available

properties

material property

values
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Exercise: Cooling of electronic components
 part b): defining material properties – delete standard material

 RMB on ‘Structural Steel’

 Delete
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Exercise: Cooling of electronic components
 part b): defining material properties – import materials from xml-file

 Main Menu => File => Import Engineering Data …

 Select ‘Material Properties.xml’

 Notice that for Carbon Fiber Laminate an orthotropic thermal conductivity is selected

=> medium conductivity in fiber directions, low conductivity perpendicular to fiber directions

 Return to Project-Sheet:

 TB: 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation

 Double-Click on ‘Model’

outline

(set-up)

details view



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 35 von 99

Exercise: Cooling of electronic components
 part c): simplified thermal simulation – assigning materials

 Outline => Model => expand Geometry

 LMB on one Solid (or mark all Solids with identical materials)

 Details View => Material => Assignment => choose material for marked solid(s)
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – check assignment

 Outline => Model => Geometry (LMB)

 Details View => Display Style => Material
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing remarks 

 Notice: A good mesh quality is needed to obtain good results

 Meshing with standard values can lead to an insufficient mesh quality (here scewness for full 

model)
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Outline => Mesh

 Toolbars =>            : Select circumferential lines at end of pipe => RMB => Insert => Sizing

 Details View 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Toolbars =>            : Select end face of pipe => RMB => Insert => Sizing

 Details View 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Toolbars =>            : Select pipe body => RMB => Insert => Method

 Details View 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Toolbars =>            : Select pipe => RMB => Generate Mesh on Selected Bodies
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Toolbars =>            : Select front face of foam => RMB => Insert => Sizing

 Details View 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Toolbars =>            : Select foam => RMB => Insert => Method

 Details View 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Try to modify number of elements along vertical lines by your own 

 Outline => Mesh => RMB => Generate Mesh



1

2

2
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – meshing

 Note: All bodies in a part are automatically connected and share nodes at the interface

 The mesh of the electronic components is different from the mesh of the subjacent laminate,

here the software automatically generates contact elements (bonded contact)
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – boundary conditions

 Toolbars =>             => select all electronic components (use ‘Ctrl’ & select each box) 

 Outline => Steady-State Thermal => RMB => Insert => Internal Heat Generation

 Details View

 Notice: the volume of one box is 7.5mm³ => 1.5 W / 7.5 mm³ = 0.2 W/mm³ 
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – boundary conditions and solution

 Toolbars =>             => select inner surface of pipe

 Outline => Steady-State Thermal => RMB => Insert => Convection

 Details View

 Toolbars =>


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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – post-processing

 Outline => Steady-State Thermal => Solution => RMB => Insert => Thermal =>Temperatures
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – post-processing

 Outline => Steady-State Thermal => Solution => RMB Evaluate All Results
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Exercise: Cooling of electronic components
 part c): simplified thermal simulation – adapted boundary conditions

 Main problem of current solution:

heating up of helium while passing the pipe is not considered but is important in this case!

 Possible options:

=> modify ambient temperature in convection boundary condition by analytically assessing 

the temperature rise in the helium (for this simple case possible)

or

=> d) more precise simulation using fluid elements
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – solver units

 Main Menu => Units => select ‘Metric (tonne,mm,s,°C,mA,N,mV)’
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – new project

 Project Schematic => Project A: Steady-State Thermal => RMB => Duplicate

 Open ‘DesignModeler’

(double-click on Geometry) 
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – activate center line of pipe

 Tree Outline => Parts, Bodies => Line Body => RMB => Unsuppress Body

 Main Menu =>

File => 

Close Design Modeler
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – activate center line of pipe

 Project Schematic => Project B => double-click on ‘Model’

 Outline => Project => Model => Geometry  => Line Body => LMB

 Details View

(Note: Assignment not important

for calculation but a material

has to be selected)
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – meshing

 Outline Mesh

 Toolbars =>               select center line => RMB => Insert => Sizing

 Details View:
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements - commands

Meshing the center line of pipe with fluid elements and assigning material properties:

 Outline => Geometry => Line Body => RMB => Insert => Command
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements - commands

 Outline => Geometry => Line Body => Commands (APDL) => RMB => Import …

=> ‘LineBody-Commands.txt’
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements - commands

the following commands were imported:

!mesh
ET,matid,fluid116
KEYOPT,matid,1,1 !TEMP degrees of freedom only (no pressure)

KEYOPT,matid,2,1 !2 nodes and convection information passed to SURF152
HD=1.8 !hydraulic diameter in mm
CS=3.14159*1.8*1.8/4 !cross section in mm
R,matid,HD,CS,1 !R,matid,hydraulic diameter,cross section,number of flow channels ,,,
! material
mp,dens,matid,1.634e-12  !helium density in t/mm³
mp,c,matid,5.2e9 !helium specific heat capacity in mm²/K/s²

Notice: In principle ANSYS Workbench will consider units – but when using commands in 

Workbench the user is responsible to enter all values in the correct unit system!

If you run the same simulation using the SI-Unit-System (m, kg, s, V …) in Workbench you will 

get incorrect results.
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – meshing

 Mesh geometry

sequence like in part c) 

- first mesh pipe

- then mesh foam

- then generate complete mesh



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 60 von 99

Exercise: Cooling of electronic components
 part d): simulation with fluid elements – boundary conditions

Convective heat transfer boundary conditions are not needed here:

 Outline => Steady-State Thermal => Convection => RMB => Suppress

Specify fluid inlet temperature:

 Toolbars =>             select start point of centerline => RMB => Insert => Temperature 

 Details View:
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – boundary conditions

Heat transfer from pipe to fluid elements has to be defined:

 Outline => Named Selections => LMB 

 Toolbars =>             select inner surface of pipe => RMB => Create Named Selection

 SelectionName:
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – boundary conditions

 Outline => Named Selections => LMB 

 Toolbars =>             select center line body => RMB => Create Named Selection

(important)

 Selection Name:
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – boundary conditions

 Outline => Steady-State Thermal => RMB => Insert => Command

 Outline => Steady-State Thermal => Commands (APDL) => RMB => Import

=> ‘SteadyStateThermal-Commands.txt’

the following commands were imported::

finish
/PREP7
!----
! surface effect elements
et,200,152
keyopt,200,8,2 !Hf at average T
type,200
! generate surface elements on existing mesh of pipe with closest fluid element node
ndsurf,'ConvectionSurface','Fluid',3
!boundary conditions
cmsel,s,Fluid
sfe,all,,hflux,,2.5e-7 !mass flow rate in t/s (due to symmetry only 1/2 of total mass flow rate)
esel,s,type,,200
sfe,all,,conv,,4 !heat transfer coefficient in t/K/s³
!----
alls
fini
/solu
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – boundary conditions

 Main Menu => Units => Metric (mm, t, N, s, mV, mA) => LMB
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Exercise: Cooling of electronic components
 part d): simulation with fluid elements – solving and post-processing

 Toolbars =>

 Outline => Steady-State Thermal => Solution => Temperature => LMB

For comparison: previous results of c):
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Introduction to CFD
CFD (computational fluid dynamics)
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Exercise: Cooling of electronic components
 part e): CFD simulation – CFX project

 Project => Toolbox => Analysis Systems => Fluid Flow (CFX) => 

drag and drop (LMB) to Project Schematic
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Exercise: Cooling of electronic components
 part e): CFD simulation – CFX project

 Project => Project Schematic => Project A => Geometry =>

drag and drop (LMB) to Project C Geometry
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Exercise: Cooling of electronic components
 part e): CFD simulation – CFX project

 Project => Project Schematic => Geometry Connection => RMB => Delete

 Open Geometry (double click LMB)
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Exercise: Cooling of electronic components
 part e): CFD simulation – geometry: activate fluid region

 Tree Outline => Parts, Bodies => Part =>               RMB => Unsuppress Body

 Main Manu => File => Close DesignModeler
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Exercise: Cooling of electronic components
 part e): CFD simulation – meshing

Open Meshing:

 Project => Project Schematic => Project C => Mesh (double click LMB)

Element Size on end faces of fluid and pipe

 Outline => Project => Mesh => LMB

 Toolbars =>             => select faces (second face with ‘Ctrl’) => RMB => Insert => Sizing 

 Details View
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Exercise: Cooling of electronic components
 part e): CFD simulation – meshing

 Toolbars =>             => select fluid body => RMB => Insert => Method

 Details View
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Exercise: Cooling of electronic components
 part e): CFD simulation – meshing

For the heat transfer calculation a fine mesh at the fluid-solid interface is needed

– here a mesh inflation is used at the end face

 Toolbars =>             => select fluid end faces => RMB => Insert => Inflation 

 Details View
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Exercise: Cooling of electronic components
 part e): CFD simulation – meshing

Try yourself:

 Sweep method for pipe body with manual source (end surface) and 1mm element size in sweep direction

 RMB on end surface of pipe => ‘Face Meshing’ with default values (=> mapped mesh)

 Number of element divisions (element size) for pipe wall thickness: 3 (behavior: ‘hard’)

 Number of element divisions for circumferential lines of pipe: 25 (‘hard’)

 Number of element divisions in foam body between pipe and laminate: 3 (‘hard’)

 Number of element divisions in width direction: 10 (‘hard’)

 Element size on end surface of foam: 0.4 mm

 Sweep method for foam (default settings in Details View)

 Element size on bodies of electronic components: 0.3 mm

 Number of element divisions for laminate thickness: 3 (‘hard’)

 Number of element divisions for thickness of electronic components: 2

 Meshing sequence: 

- pipe wall

- fluid body

- complete mesh
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Exercise: Cooling of electronic components
 part e): CFD simulation – meshing 

For the setup in CFX ‘Named Selections’ are needed:

 Toolbars =>             select end surface of fluid => RMB => Create Named Selection

 Selection Name
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Exercise: Cooling of electronic components
 part e): CFD simulation – meshing 

Try yourself:

 Front surface of fluid body => Named Selection ‘Inlet’

 Symmetry face of fluid body => Named Selection ‘Symmetry’

 Fluid body => Named Selection ‘Fluid’

 Pipe body => Named Selection ‘Pipe’

 Foam body => Named Selection ‘Foam’

 Carbon fiber laminate body => Named Selection ‘Laminate’

 Electronic components => Named Selection ‘Electronics’

 Main Menu => File => 

Close Meshing

 Project Schematic => Project C

=> Mesh => RMB => Update
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Exercise: Cooling of electronic components
 part e): CFD simulation – activate beta options (needed later on) 

Project Overview:

 Main Menu => Tools => Options =>

Appearance => Beta Options => activate

Start Setup:

 Project Schematics => Project C

=> Setup => double click LMB
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup

 Outline => Simulation => Flow Analysis 1 => Analysis Type => double click LMB



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 79 von 99

Exercise: Cooling of electronic components
 part e): CFD simulation – setup materials

Import material properties from file

 Main Menu => File => Import => CCL … (choose directory with materials-CFX.ccl file)

Notice: 

 thermal conductivity is important for all solids, but orthotropic values 

for the laminate can not be defined in the GUI (workaround available)

 material properties like density and heat capacity have to be defined 

for solids but are not important for the results of a steady-state 

calculation.

 for Helium all thermodynamic and transport properties 

are important for the flow simulation
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup materials

Check properties for helium @ 10 bar

 Outline => Simulation => Materials => Helium => double click LMB



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 81 von 99

Exercise: Cooling of electronic components
 part e): CFD simulation – setup domains

For each material a domain has to be defined. Domain interfaces will be generated automatically

 Outline => Simulation => Flow Analysis 1 => RMB => Insert => Domain
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup domains

Fluid domain settings – Basic Settings (will automatically open):

Notice: 

 If a ‘named selection’ is found with the same name, this will 

be pre-selected as location (here the fluid volume mesh).

 Here a domain material has to be selected from the material 

library

 Fluid pressure
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup domains

Fluid domain settings – Fluid Models:

Notice: 

 Since temperatures should be calculated the option ‘thermal 

energy’ has to be chosen.

 Since the Reynolds number is greater then 10000 we will 

habe a fully turbulent flow – so a turbulence model has to be 

activated (SST is the preferred one)

 Wall functions will consider the viscous boundary layer near 

the walls, if the mesh is not fine enough.
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup domains

Fluid domain settings - initialization:

Notice: 

 Setting realistic initial conditions may improve convergency

 Mean flow velocity
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup domains

Define Solid Domains

 Outline => Simulation => Flow Analysis 1 => RMB => Insert => Domain
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Exercise: Cooling of electronic components
 part e): CFD simulation – setup domains

Solid domain settings (Pipe) – Basic Settings (will automatically open):

Try yourself to set up domains for:

- Foam

- Laminate

- Electronics
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Exercise: Cooling of electronic components
 part e): CFD simulation – boundary conditions

Heat transfer for interfaces

 Outline => Simulation => Interfaces => Default Fluid Solid Interface => double click LMB

 Same for ‘Default Solid Solid Interface’
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Exercise: Cooling of electronic components
 part e): CFD simulation – boundary conditions

Flow conditions

 Outline => Simulation => Flow Analysis 1 => Fluid => RMB => Insert => Boundary
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Exercise: Cooling of electronic components
 part e): CFD simulation – boundary conditions

Inlet conditions for helium flow

Notice: 

 If a ‘named selection’ is found with the same name, this will 

be pre-selected as location (here the inlet face mesh).

 Since the calculation is done for a half-model only half of the 

total mass flow rate is considered here.

Select units [g s^-1] from drop down list at end of text field 

(visible during editing text field).

 Inlet temperature
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Exercise: Cooling of electronic components
 part e): CFD simulation – boundary conditions

Notice: 

 If a ‘named selection’ is found with the same name, this will 

be pre-selected as location (here the inlet face mesh).

 Relative static outlet pressure is based on the system 

pressure of 10 bar defined before

=> absolute outlet pressure is 10bar

 Outline => Simulation => Flow Analysis 1 => Fluid => RMB => Insert => Boundary 

Boundary name: ‘Outlet’

 Outline => Simulation => Flow Analysis 1 => Fluid => RMB => Insert => Boundary 

Boundary name: ‘Symmetry’ => location ‘Symmetry’

(no further settings needed)
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Exercise: Cooling of electronic components
 part e): CFD simulation – boundary conditions

Heat generation

 Outline => Simulation => Flow Analysis 1 => Electgronics => RMB => Insert => Subdomain
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Exercise: Cooling of electronic components
 part e): CFD simulation – boundary conditions

Inlet conditions for helium flow

Notice: 

 The heat is generated on all domain bodies

=> Named Selection ‘Electronics’ can be selected here again

 Since the calculation is done for a half-model only half of the 

total heat generation (1/2 of 36 W) is considered
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Exercise: Cooling of electronic components
 part e): CFD simulation – solution control

Increase convergency by an aggressive ‘Length Scale Option’ 

 Outline => Simulation => Flow Analysis 1 => Solver => Solver Control => double click LMB

Leave Pre-Processor

 Main Menu => Close CFX-Pre 



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 94 von 99

Exercise: Cooling of electronic components
 part e): CFD simulation – solve problem

 Main Menu => View => Properties (must be activated)

 Project Schematic => Project C => Solution => LMB

Notice: 

 The option –ccl can be used to include additional command not provided by the GUI

 Specify the complete directory, where the aniso.ccl file is located



Georgian German Science Bridge – Autumn Lectures 2015.10.12.-13. J. Wolters – ZEA-1        

Seite 95 von 99

Exercise: Cooling of electronic components
 part e): CFD simulation – solve problem

Start simulation

 Project Schematic => Project C => Solution => double click LMB

=> Define Run => Start Run

 Convergency control:
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Exercise: Cooling of electronic components
 part e): CFD simulation – post-processing results

 Project Schematic => Project C => Results => double click LMB
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Exercise: Cooling of electronic components
 part e): CFD simulation – post-processing results

 Main Menu => Insert => Contour => Name: ‘Temperatures’
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Exercise: Cooling of electronic components
 part e): CFD simulation – post-processing results

 Details View
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